summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-01-20 20:43:13 +0000
committerPeter Wu <peter@lekensteyn.nl>2020-01-20 21:25:26 +0000
commite92ab03b6b40f886c2cb81551e1a9c6c97818c3e (patch)
tree9ee5938c037677195f9abdc1c6377308ca1da164 /debian
parent7d42200919e5fa63caf12bda7e2dd46dc1210b1a (diff)
downloadrspamd-e92ab03b6b40f886c2cb81551e1a9c6c97818c3e.tar.gz
rspamd-e92ab03b6b40f886c2cb81551e1a9c6c97818c3e.zip
[Minor] Debian: update arches and versions in build dependencies
* glib 2.28 is the current minimum declared in CMakeLists.txt, but even Jessie satisfies that requirement. Remove it. * Use DEB_HOST_ARCH for "The Debian architecture of the host machine" instead of DEB_TARGET_ARCH which is relevant for cross-compiling only. * Update luajit arches based on https://packages.debian.org/sid/luajit * Added arm64, mips64el, ppc64, ppc64el (stretch-backports / buster). * Removed kfreebsd-i386 and 32-bit powerpc (removed in Jessie). * Removed powerpcspe (unofficial port with outdated luajit). * Maintained mips (removed after buster).
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules12
2 files changed, 13 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index ab2614cb2..293777037 100644
--- a/debian/control
+++ b/debian/control
@@ -5,17 +5,17 @@ Maintainer: Mikhail Gusarov <dottedmag@debian.org>
Build-Depends: cmake,
debhelper (>= 10),
libcurl4-openssl-dev,
- libglib2.0-dev (>= 2.16.0),
+ libglib2.0-dev,
libhyperscan-dev [amd64 i386],
libicu-dev,
libjemalloc-dev,
- libluajit-5.1-dev [amd64 armel armhf i386 kfreebsd-i386 mips mipsel powerpc powerpcspe] | liblua5.1-dev,
+ libluajit-5.1-dev [amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64 ppc64el] | liblua5.1-dev,
libmagic-dev,
libpcre2-dev,
libsodium-dev,
libsqlite3-dev,
libssl-dev (>= 1.0),
- libunwind-dev | libunwind8-dev,
+ libunwind-dev,
perl,
ragel,
zlib1g-dev
diff --git a/debian/rules b/debian/rules
index d78c8ee5a..dd1f27a1e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,15 @@
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export ASAN_OPTIONS=detect_leaks=0
-ifneq ($(filter $(DEB_TARGET_ARCH),amd64 i386),)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifneq ($(filter $(DEB_HOST_ARCH),amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64 ppc64el),)
+ ENABLE_LUAJIT := ON
+else
+ ENABLE_LUAJIT := OFF
+endif
+
+ifneq ($(filter $(DEB_HOST_ARCH),amd64 i386),)
ENABLE_HYPERSCAN := -DENABLE_HYPERSCAN=ON
else
ENABLE_HYPERSCAN :=
@@ -27,7 +35,7 @@ override_dh_auto_configure:
-DDEBIAN_BUILD=1 \
-DENABLE_JEMALLOC=ON \
-DENABLE_PCRE2=OFF \
- -DENABLE_LUAJIT=ON \
+ -DENABLE_LUAJIT=$(ENABLE_LUAJIT) \
-DENABLE_LIBUNWIND=ON \
-DWANT_SYSTEMD_UNITS=ON \
$(ENABLE_HYPERSCAN)