aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rspamd.com>2023-02-18 19:19:05 +0000
committerVsevolod Stakhov <vsevolod@rspamd.com>2023-02-18 19:19:05 +0000
commit2f0d146b19db2d60b512855e8999dc2bcab22734 (patch)
tree84b672e156c67cb0ea047da443ed57bc7d1c655a /debian
parenta48d6fc4dfed4a91211ef8f976ec9e833da12a0d (diff)
downloadrspamd-2f0d146b19db2d60b512855e8999dc2bcab22734.tar.gz
rspamd-2f0d146b19db2d60b512855e8999dc2bcab22734.zip
[Minor] Further debian packages fixes
Diffstat (limited to 'debian')
-rw-r--r--debian/compat2
-rwxr-xr-xdebian/rules12
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/compat b/debian/compat
index ec635144f..f599e28b8 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/rules b/debian/rules
index ce3ebf488..d12924d22 100755
--- a/debian/rules
+++ b/debian/rules
@@ -68,9 +68,9 @@ build_%:
override_dh_strip: $(patsubst %,strip_%,$(FLAVORS))
strip_%:
if [ "$*" = "asan" ]; then \
- dh_strip --dbg-package=rspamd-dbg-asan ; \
+ dh_strip -prspamd-asan --dbg-package=rspamd-dbg-asan ; \
else \
- dh_strip --dbg-package=rspamd-dbg ; \
+ dh_strip -prspamd --dbg-package=rspamd-dbg ; \
fi
override_dh_makeshlibs:
@@ -80,8 +80,16 @@ override_dh_auto_install: $(patsubst %,install_%,$(FLAVORS))
install_%:
if [ "$*" = "asan" ]; then \
cd $(builddir)$* && make install DESTDIR=../../../debian/rspamd-asan ; \
+ cd ../../../debian/rspamd-asan && mkdir -p var/lib/rspamd \
+ var/log/rspamd \
+ etc/rspamd/local.d \
+ etc/rspamd/override.d ; \
else \
cd $(builddir)$* && make install DESTDIR=../../../debian/rspamd ; \
+ cd ../../../debian/rspamd && mkdir -p var/lib/rspamd \
+ var/log/rspamd \
+ etc/rspamd/local.d \
+ etc/rspamd/override.d ; \
fi
override_dh_fixperms: