aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-01-21 03:54:27 +0000
committerPeter Wu <peter@lekensteyn.nl>2020-01-21 04:00:46 +0000
commitaee58d4583b1aec4db06aedf9072205e5e184970 (patch)
treea99aac32d135cae1fc8498599df85ca8d3098a0f /debian
parent3af38b800677a463b97588af383caacf09ce31d1 (diff)
downloadrspamd-aee58d4583b1aec4db06aedf9072205e5e184970.tar.gz
rspamd-aee58d4583b1aec4db06aedf9072205e5e184970.zip
[Minor] Debian: set BUILD_WITH_INSTALL_RPATH=ON
* Use the install RPATH to avoid relinking at install time. * This additionally ensures reproducible builds invariant of the build directory since build paths such as `X/src:X/contrib/replxx:...` are no longer embedded in the binary. * This assumes that binaries are not ran at build time. If this is needed, CMAKE_BUILD_RPATH_USE_ORIGIN=ON can be used instead (requires CMake 3.14). For older CMake, try setting LD_LIBRARY_PATH.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 42f98643b..17ebd6eb1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,7 @@ override_dh_auto_configure:
-DINCLUDEDIR=/usr/include \
-DSYSTEMDDIR=/lib/systemd/system \
-DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON \
-DDEBIAN_BUILD=1 \
-DENABLE_JEMALLOC=ON \
-DENABLE_PCRE2=OFF \