summaryrefslogtreecommitdiffstats
path: root/rpm/rspamd.spec
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rspamd.com>2023-02-08 12:37:05 +0000
committerVsevolod Stakhov <vsevolod@rspamd.com>2023-02-08 12:37:05 +0000
commit1a789a0fcfb0db40c3c5853cd09d9a5e971aa83c (patch)
tree3f60a604b8fc376d9d0960f35bbbe0d394197c5d /rpm/rspamd.spec
parent2958e580d85c690f2dd5a8def4ce9502c9d6da84 (diff)
downloadrspamd-1a789a0fcfb0db40c3c5853cd09d9a5e971aa83c.tar.gz
rspamd-1a789a0fcfb0db40c3c5853cd09d9a5e971aa83c.zip
[Minor] More fixes for the rpm spec
Diffstat (limited to 'rpm/rspamd.spec')
-rw-r--r--rpm/rspamd.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/rpm/rspamd.spec b/rpm/rspamd.spec
index 85aab6018..19f9e3634 100644
--- a/rpm/rspamd.spec
+++ b/rpm/rspamd.spec
@@ -18,14 +18,21 @@ BuildRequires: gcc-c++
%endif
BuildRequires: file-devel
BuildRequires: glib2-devel
-BuildRequires: hyperscan-devel
-BuildRequires: jemalloc-devel
BuildRequires: lapack-devel
BuildRequires: libevent-devel
BuildRequires: libicu-devel
BuildRequires: libsodium-devel
BuildRequires: libunwind-devel
+%ifarch x86_64 amd64
+BuildRequires: hyperscan-devel
+BuildRequires: jemalloc-devel
BuildRequires: luajit-devel
+%else
+BuildRequires: lua-devel
+%endif
+%ifarch arm64 aarch64
+BuildRequires: vectorscan-devel
+%endif
BuildRequires: openblas-devel
BuildRequires: openssl-devel
BuildRequires: pcre2-devel
@@ -43,7 +50,7 @@ with big amount of mail and can be easily extended with own filters written in
lua.
%prep
-%setup -q
+%setup -q -n rspamd-%{version}
%build
%if 0%{?el7}
@@ -74,9 +81,13 @@ lua.
-DNO_SHARED=ON \
-DDEBIAN_BUILD=1 \
-DENABLE_LIBUNWIND=ON \
+%ifarch x86_64 amd64 arm64 aarch64
-DENABLE_HYPERSCAN=ON \
+%endif
+%ifarch x86_64 amd64
-DENABLE_JEMALLOC=ON \
-DENABLE_LUAJIT=ON \
+%endif
-DENABLE_BLAS=ON
%{__make} %{?jobs:-j%jobs}