aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-04-30 17:23:58 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-04-30 17:23:58 +0100
commit01e1758608d2bf6f466e7fa8897d8a192e427520 (patch)
tree2011de3fe1aaf5825234298c283f0d72d8f7bcc9 /src/CMakeLists.txt
parent7256893004d0027de0b81410e7b379a03cdbe719 (diff)
downloadrspamd-01e1758608d2bf6f466e7fa8897d8a192e427520.tar.gz
rspamd-01e1758608d2bf6f466e7fa8897d8a192e427520.zip
Webui is now controller.
Old controller is kept in legacy_controller.c.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1d04476f8..b8824b85a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -71,13 +71,12 @@ ADD_SUBDIRECTORY(libserver)
ADD_SUBDIRECTORY(libmime)
ADD_SUBDIRECTORY(client)
-SET(RSPAMDSRC modules.c
+SET(RSPAMDSRC ${CMAKE_CURRENT_BINARY_DIR}/modules.c
controller.c
fuzzy_storage.c
lua_worker.c
main.c
smtp_proxy.c
- webui.c
worker.c)
SET(PLUGINSSRC plugins/surbl.c
@@ -88,7 +87,7 @@ SET(PLUGINSSRC plugins/surbl.c
plugins/dkim_check.c)
SET(MODULES_LIST surbl regexp chartable fuzzy_check spf dkim)
-SET(WORKERS_LIST normal controller smtp_proxy fuzzy lua webui)
+SET(WORKERS_LIST normal controller smtp_proxy fuzzy lua)
AddModules(MODULES_LIST WORKERS_LIST)
LIST(LENGTH PLUGINSSRC RSPAMD_MODULES_NUM)