summaryrefslogtreecommitdiffstats
path: root/src/libcryptobox/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-06 15:04:41 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-06 15:04:41 +0000
commitea46a2f8c7732b13be1e4cee7618c7293706aa55 (patch)
tree3bee0ce46d5dbc1f3822f1f11ae62248422c590b /src/libcryptobox/CMakeLists.txt
parentb14cc5bc89dc9d925e1de775ed666354a3672b2b (diff)
downloadrspamd-ea46a2f8c7732b13be1e4cee7618c7293706aa55.tar.gz
rspamd-ea46a2f8c7732b13be1e4cee7618c7293706aa55.zip
Add platform detector based on cpuid.
Diffstat (limited to 'src/libcryptobox/CMakeLists.txt')
-rw-r--r--src/libcryptobox/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libcryptobox/CMakeLists.txt b/src/libcryptobox/CMakeLists.txt
index cf87c2604..a7d8e5a89 100644
--- a/src/libcryptobox/CMakeLists.txt
+++ b/src/libcryptobox/CMakeLists.txt
@@ -3,7 +3,7 @@ INCLUDE(AsmOp.cmake)
TARGET_ARCHITECTURE(ARCH)
-SET(CHACHASRC chacha20/ref.c)
+SET(CHACHASRC chacha20/chacha.c chacha20/ref.c)
SET(POLYSRC poly1305/poly1305-donna.c)
# For now we support only x86_64 architecture with optimizations