aboutsummaryrefslogtreecommitdiffstats
path: root/src/lua/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2009-12-16 20:06:29 +0300
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2009-12-16 20:06:29 +0300
commit1b1bcd6966f47a2568acee011dd4b9f18195d765 (patch)
tree219073936a703bd001699bc0ca4c70014068c26c /src/lua/CMakeLists.txt
parentb7046a0e6667e9c840b83acaf08f9ac117508eaa (diff)
downloadrspamd-1b1bcd6966f47a2568acee011dd4b9f18195d765.tar.gz
rspamd-1b1bcd6966f47a2568acee011dd4b9f18195d765.zip
* Implement pre and post classify callbacks for checking specific statfiles for this task
TODO: - add properties to get all parameters of input task - add properties to statfile object - add some normalization function for calling from classify process - document changes
Diffstat (limited to 'src/lua/CMakeLists.txt')
-rw-r--r--src/lua/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/lua/CMakeLists.txt b/src/lua/CMakeLists.txt
index 5ae12c49e..298b81025 100644
--- a/src/lua/CMakeLists.txt
+++ b/src/lua/CMakeLists.txt
@@ -2,7 +2,8 @@
SET(LUASRC lua_common.c
lua_task.c
lua_message.c
- lua_config.c)
+ lua_config.c
+ lua_classifier.c)
ADD_LIBRARY(rspamd_lua STATIC ${LUASRC})
TARGET_LINK_LIBRARIES(rspamd_lua ${LUALIB})