aboutsummaryrefslogtreecommitdiffstats
path: root/src/lua/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2011-12-12 20:14:49 +0300
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2011-12-12 20:14:49 +0300
commitce605155252dd38a76ae9411b217c2c1576849bc (patch)
tree539563cfbf723f42c72afdf8b13fd2cc48d23066 /src/lua/CMakeLists.txt
parent7ca658607cdeebe0cecbeb310cf2c99af800306f (diff)
downloadrspamd-ce605155252dd38a76ae9411b217c2c1576849bc.tar.gz
rspamd-ce605155252dd38a76ae9411b217c2c1576849bc.zip
* Add lua bindings to hiredis library
Polish some comments.
Diffstat (limited to 'src/lua/CMakeLists.txt')
-rw-r--r--src/lua/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/lua/CMakeLists.txt b/src/lua/CMakeLists.txt
index 04fa393ad..70b3f7bc1 100644
--- a/src/lua/CMakeLists.txt
+++ b/src/lua/CMakeLists.txt
@@ -8,8 +8,10 @@ SET(LUASRC lua_common.c
lua_regexp.c
lua_cdb.c
lua_xmlrpc.c
- lua_http.c)
+ lua_http.c
+ lua_redis.c)
ADD_LIBRARY(rspamd_lua STATIC ${LUASRC})
TARGET_LINK_LIBRARIES(rspamd_lua ${LUALIB})
+TARGET_LINK_LIBRARIES(rspamd_lua hiredis)
SET_TARGET_PROPERTIES(rspamd_lua PROPERTIES COMPILE_FLAGS "-DRSPAMD_LIB")