summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-28 22:15:23 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-28 22:15:23 +0000
commit2ebe497bfa1790021a51f87fa3327a7b0faa3e7b (patch)
treedff1a660e4babd226ef37e970ce49e6cedf1f7be /test/CMakeLists.txt
parente866150369bfbdf594612b53262f0ad7aa5d3524 (diff)
downloadrspamd-2ebe497bfa1790021a51f87fa3327a7b0faa3e7b.tar.gz
rspamd-2ebe497bfa1790021a51f87fa3327a7b0faa3e7b.zip
Include the whole rspamd-server for ffi.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 18a826026..51e2e77f1 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -18,7 +18,9 @@ ADD_EXECUTABLE(rspamd-test EXCLUDE_FROM_ALL ${TESTSRC})
SET_TARGET_PROPERTIES(rspamd-test PROPERTIES LINKER_LANGUAGE C)
SET_TARGET_PROPERTIES(rspamd-test PROPERTIES COMPILE_FLAGS "-DRSPAMD_TEST")
-TARGET_LINK_LIBRARIES(rspamd-test rspamd-server)
+TARGET_LINK_LIBRARIES(rspamd-test "-Wl,-whole-archive ../src/librspamd-server.a -Wl,-no-whole-archive")
+TARGET_LINK_LIBRARIES(rspamd-test rspamd-cdb)
+TARGET_LINK_LIBRARIES(rspamd-test rspamd-http-parser)
TARGET_LINK_LIBRARIES(rspamd-test ${RSPAMD_REQUIRED_LIBRARIES})
TARGET_LINK_LIBRARIES(rspamd-test stemmer)