summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-05 18:33:25 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-05 18:33:25 +0000
commit9f8d613c23448ee723e08d6640640037df3f98b3 (patch)
treea8e0561a003e831959ba8ddceb28e9812176cb17 /test/CMakeLists.txt
parentafbe7a857b990fc524573f402131c0453e4a0104 (diff)
downloadrspamd-9f8d613c23448ee723e08d6640640037df3f98b3.tar.gz
rspamd-9f8d613c23448ee723e08d6640640037df3f98b3.zip
Properly link rspamd_server on darwin.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1e0495c1f..5d1f0aaab 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -21,7 +21,7 @@ ADD_DEPENDENCIES(rspamd-test rspamd-server)
IF(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
TARGET_LINK_LIBRARIES(rspamd-test "-Wl,-whole-archive ../src/librspamd-server.a -Wl,-no-whole-archive")
ELSE(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- TARGET_LINK_LIBRARIES(rspamd-test rspamd-server)
+ TARGET_LINK_LIBRARIES(rspamd-test "-Wl,-force_load ../src/librspamd-server.a")
ENDIF(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
TARGET_LINK_LIBRARIES(rspamd-test rspamd-cdb)
TARGET_LINK_LIBRARIES(rspamd-test rspamd-http-parser)