summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-09-01 13:30:56 +0200
committerPetr Vaněk <arkamar@atlas.cz>2021-09-02 10:07:37 +0200
commitd37a3764e9889e6de0a7341ba3195ee8a314de23 (patch)
treeb7cf8406d6a4e38de2caee125048652deeff8906 /test/CMakeLists.txt
parent760522c4da986f19e864da6123ba938f5e7d25d2 (diff)
downloadrspamd-d37a3764e9889e6de0a7341ba3195ee8a314de23.tar.gz
rspamd-d37a3764e9889e6de0a7341ba3195ee8a314de23.zip
Add SYSTEM_DOCTEST cmake option
This gives packagers option to use system version of doctest rather than bundled one. It is disabled by default. Additionally, there is no need to link rspamd-test-cxx with doctest as it is is single header library. Main reason for this change is that currently bundled version of doctest-2.4.5 can't compile with glibc-2.34 [1]. However, this issue was already fixed in upstream doctest-2.4.6 [2] in commit [3]. With this, packagers can just bump doctest to fixed version. [1] https://github.com/onqtam/doctest/issues/473 [2] https://github.com/onqtam/doctest/blob/master/CHANGELOG.md#246-2021-03-22 [3] https://github.com/onqtam/doctest/commit/099d5414e97244ec44cf46b14cd176b3a3dc52e3
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 9e56cbad7..08e9556f3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -24,9 +24,7 @@ SET(CXXTESTSSRC rspamd_cxx_unit.cxx)
ADD_EXECUTABLE(rspamd-test-cxx EXCLUDE_FROM_ALL ${CXXTESTSSRC})
SET_TARGET_PROPERTIES(rspamd-test-cxx PROPERTIES LINKER_LANGUAGE CXX)
ADD_DEPENDENCIES(rspamd-test-cxx rspamd-server)
-ADD_DEPENDENCIES(rspamd-test-cxx doctest)
TARGET_LINK_LIBRARIES(rspamd-test-cxx PRIVATE rspamd-server)
-TARGET_LINK_LIBRARIES(rspamd-test-cxx PRIVATE doctest)
SET_TARGET_PROPERTIES(rspamd-test-cxx PROPERTIES LINKER_LANGUAGE CXX)
IF(NOT "${CMAKE_CURRENT_SOURCE_DIR}" STREQUAL "${CMAKE_CURRENT_BINARY_DIR}")