aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2012-05-29 03:07:23 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2012-05-29 03:07:23 +0400
commit851ffca79a7c57077f93417a4129226e97123a58 (patch)
tree2615dec0e56e0853ee40e115b9592d6bc6ba6a08 /test/CMakeLists.txt
parentd0779b60585cde616c53d6639e87cdb968ccb29c (diff)
downloadrspamd-851ffca79a7c57077f93417a4129226e97123a58.tar.gz
rspamd-851ffca79a7c57077f93417a4129226e97123a58.zip
* Write tests for DKIM signature and key parsers.
Fix DKIM parsers.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5e20e25e4..322229cad 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -6,7 +6,8 @@ SET(TESTSRC rspamd_expression_test.c
rspamd_test_suite.c
rspamd_url_test.c
rspamd_dns_test.c
- rspamd_async_test.c)
+ rspamd_async_test.c
+ rspamd_dkim_test.c)
ADD_EXECUTABLE(rspamd-test EXCLUDE_FROM_ALL ${TESTSRC})
SET_TARGET_PROPERTIES(rspamd-test PROPERTIES LINKER_LANGUAGE C)
@@ -34,3 +35,6 @@ IF(ENABLE_LUAJIT MATCHES "ON")
ELSE(ENABLE_LUAJIT MATCHES "ON")
TARGET_LINK_LIBRARIES(rspamd-test "${LUA_LIBRARY}")
ENDIF(ENABLE_LUAJIT MATCHES "ON")
+IF(OPENSSL_FOUND)
+ TARGET_LINK_LIBRARIES(rspamd-test ${OPENSSL_LIBRARIES})
+ENDIF(OPENSSL_FOUND)