aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-10-23 11:51:53 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-10-23 11:51:53 +0100
commitc5e769ec0ce3d7347276809d79d7dcb81aae8324 (patch)
treeaa3f55253232d2a2de9faa9a8370e1c1b956334a /test/CMakeLists.txt
parent00f687383ae2ea5f3e39840989541e4704887f01 (diff)
downloadrspamd-c5e769ec0ce3d7347276809d79d7dcb81aae8324.tar.gz
rspamd-c5e769ec0ce3d7347276809d79d7dcb81aae8324.zip
Allow conditional build of snowball.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1e8fcb67f..241565b19 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -25,7 +25,9 @@ ENDIF(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
TARGET_LINK_LIBRARIES(rspamd-test rspamd-cdb)
TARGET_LINK_LIBRARIES(rspamd-test rspamd-http-parser)
TARGET_LINK_LIBRARIES(rspamd-test ${RSPAMD_REQUIRED_LIBRARIES})
-TARGET_LINK_LIBRARIES(rspamd-test stemmer)
+IF (ENABLE_SNOWBALL MATCHES "ON")
+ TARGET_LINK_LIBRARIES(rspamd-test stemmer)
+ENDIF()
TARGET_LINK_LIBRARIES(rspamd-test rspamd-actrie)
ADD_CUSTOM_TARGET(rspamd-func-test COMMAND