summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e19f43ac..9398bd78a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -657,6 +657,9 @@ ProcessPackage(GLIB2 LIBRARY glib-2.0 INCLUDE glib.h
ProcessPackage(GMODULE2 LIBRARY gmodule-2.0 INCLUDE glib.h
INCLUDE_SUFFIXES include/glib include/glib-2.0
ROOT ${GLIB_ROOT_DIR} MODULES gmodule-no-export-2.0>=2.28 gmodule-2.0>=2.28)
+ProcessPackage(GOBJECT LIBRARY gobject-2.0 INCLUDE glib.h
+ INCLUDE_SUFFIXES include/glib include/glib-2.0
+ ROOT ${GLIB_ROOT_DIR} MODULES gobject-no-export-2.0>=2.28 gobject-2.0>=2.28)
IF(GLIB_ROOT_DIR)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "-lpthread")
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "-lffi")