aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 889debe88..8091bb802 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -925,4 +925,9 @@ INSTALL(FILES "doc/rspamc.1" DESTINATION ${MANDIR}/man1)
# Install webui
IF(INSTALL_WEBUI MATCHES "ON")
INSTALL(DIRECTORY "interface/" DESTINATION ${WWWDIR} PATTERN ".git" EXCLUDE)
-ENDIF(INSTALL_WEBUI MATCHES "ON") \ No newline at end of file
+ENDIF(INSTALL_WEBUI MATCHES "ON")
+
+ADD_CUSTOM_TARGET(dist ${CMAKE_SOURCE_DIR}/dist.sh
+ "${CMAKE_BINARY_DIR}/rspamd-${RSPAMD_VERSION}.tar.xz"
+ COMMENT "Create source distribution"
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}) \ No newline at end of file