aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9bb50642..44ebd8c3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -472,6 +472,13 @@ int main(int argc, char **argv) {
}
" HAVE_ATOMIC_BUILTINS)
+CHECK_C_SOURCE_RUNS("#include <stdio.h>
+int main() {
+ __builtin_cpu_init();
+ printf(\"%d\", __builtin_cpu_supports(\"avx\"));
+ return 0;
+}" HAVE_BUILTIN_CPU_SUPPORTS)
+
IF (NOT HAVE_ATOMIC_BUILTINS)
MESSAGE(STATUS "atomic builtins are -NOT- supported")
ELSE ()