aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libottery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libottery/CMakeLists.txt')
-rw-r--r--contrib/libottery/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/contrib/libottery/CMakeLists.txt b/contrib/libottery/CMakeLists.txt
index a2b3d8c0a..3ea5658f3 100644
--- a/contrib/libottery/CMakeLists.txt
+++ b/contrib/libottery/CMakeLists.txt
@@ -2,8 +2,11 @@ SET(OTTERYSRC chacha_merged.c
ottery.c
ottery_cpuinfo.c
ottery_entropy.c
- ottery_global.c)
+ ottery_global.c chacha_cryptobox.c)
ADD_LIBRARY(ottery STATIC ${OTTERYSRC})
+
+SET(OTTERY_CFLAGS "-DBUILD_RSPAMD")
if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
- set_target_properties(ottery PROPERTIES COMPILER_FLAGS "-O3")
-endif () \ No newline at end of file
+ SET(OTTERY_CFLAGS "${OTTERY_CFLAGS} -O3")
+endif ()
+set_target_properties(ottery PROPERTIES COMPILE_FLAGS "${OTTERY_CFLAGS}") \ No newline at end of file