aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/xxhash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/xxhash/CMakeLists.txt')
-rw-r--r--contrib/xxhash/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/contrib/xxhash/CMakeLists.txt b/contrib/xxhash/CMakeLists.txt
index 8caf319e4..e15eeaf53 100644
--- a/contrib/xxhash/CMakeLists.txt
+++ b/contrib/xxhash/CMakeLists.txt
@@ -6,4 +6,8 @@ IF(ENABLE_FULL_DEBUG MATCHES "OFF")
if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
SET_TARGET_PROPERTIES(xxhash PROPERTIES COMPILE_FLAGS "-O3")
endif ()
+else()
+ADD_DEFINITIONS(-DXXH_NO_INLINE_HINTS=1)
ENDIF()
+
+set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DXXH_NO_INLINE_HINTS=1")