summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/postinst2
-rwxr-xr-xdebian/rules4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/postinst b/debian/postinst
index 4c39b569a..6330486c2 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -20,8 +20,6 @@ case "$1" in
$SERVER_USER
chown $SERVER_USER: $SERVER_HOME $SERVER_LOG
- chmod u=rwx,g=rx,o= $SERVER_HOME
- chmod u=rwx,g=rx,o=rx $SERVER_LOG
;;
abort-*)
diff --git a/debian/rules b/debian/rules
index 1128635c2..c12157f3e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,3 +26,7 @@ override_dh_auto_configure:
override_dh_auto_clean:
dh_auto_clean
rm -f src/modules.c
+
+override_dh_fixperms:
+ dh_fixperms
+ chmod 750 $(CURDIR)/debian/rspamd/var/lib/rspamd