aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index c958a26ea..6fc338571 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,13 @@
#!/usr/bin/make -f
%:
- dh $@ --with systemd
+ dh $@ --with systemd --builddirectory=build-deb
.PHONY: override_dh_strip
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
override_dh_auto_configure:
- dh_auto_configure -- -DCONFDIR=/etc/rspamd \
+ dh_auto_configure -- -GNinja -DCONFDIR=/etc/rspamd \
-DMANDIR=/usr/share/man \
-DRUNDIR=/run/rspamd \
-DDBDIR=/var/lib/rspamd \
@@ -38,12 +38,17 @@ override_dh_makeshlibs:
override_dh_strip:
dh_strip --dbg-package=rspamd-dbg
+override_dh_auto_build:
+ ninja -C build-deb -v
+
override_dh_auto_install:
- dh_auto_install --destdir=debian/rspamd
+ DESTDIR=$(CURDIR)/debian/rspamd ninja -C build-deb -v install
+
+override_dh_auto_test:
override_dh_auto_clean:
dh_auto_clean
- rm -f src/modules.c
+ rm -rf build-deb
override_dh_fixperms:
dh_fixperms