summaryrefslogtreecommitdiffstats
path: root/rpm/rspamd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rpm/rspamd.spec')
-rw-r--r--rpm/rspamd.spec9
1 files changed, 7 insertions, 2 deletions
diff --git a/rpm/rspamd.spec b/rpm/rspamd.spec
index 4dc8f2208..91d7cc7dc 100644
--- a/rpm/rspamd.spec
+++ b/rpm/rspamd.spec
@@ -21,8 +21,10 @@ BuildRequires: cmake3
BuildRequires: devtoolset-10-gcc-c++
%else
BuildRequires: cmake
+%if 0%{?el8}
BuildRequires: gcc-toolset-10-gcc-c++
%endif
+%endif
BuildRequires: file-devel
BuildRequires: glib2-devel
BuildRequires: lapack-devel
@@ -33,12 +35,14 @@ BuildRequires: libunwind-devel
%if 0%{?el7}
BuildRequires: devtoolset-10-libasan-devel
%else
+%if 0%{?el8}
BuildRequires: gcc-toolset-10-libasan-devel
%endif
%endif
+%endif
%ifarch x86_64 amd64
-%if 0%{?el8}
+%if 0%{?el8} || 0%{?fedora} > 10
BuildRequires: hyperscan-devel
%endif
BuildRequires: jemalloc-devel
@@ -76,9 +80,10 @@ git clone -b v2.1 https://luajit.org/git/luajit-2.0.git %{_builddir}/luajit-src
%build
%if 0%{?el7}
source /opt/rh/devtoolset-10/enable
-%else
+%elif 0%{?el8}
source /opt/rh/gcc-toolset-10/enable
%endif
+
%if 0%{getenv:LUAJIT}
pushd %{_builddir}/luajit-src && make clean && make %{?_smp_mflags} CC="gcc -fPIC" PREFIX=%{_builddir}/luajit-build && make install PREFIX=%{_builddir}/luajit-build ; popd
rm -f %{_builddir}/luajit-build/lib/*.so || true