aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-03-17 13:32:52 +0100
committerPierre Ossman <ossman@cendio.se>2015-03-17 13:32:52 +0100
commit725121715eef5b315226c0b8a0ed4cde9a273382 (patch)
treeaef787a3cb99025b970cf6873fdab33be99394d6 /CMakeLists.txt
parentfdc55e54ccfe1b3fed3b1b687ff8d874f317df3a (diff)
downloadtigervnc-725121715eef5b315226c0b8a0ed4cde9a273382.tar.gz
tigervnc-725121715eef5b315226c0b8a0ed4cde9a273382.zip
Bump Windows requirement to XP SP2
That's even more generous than Microsoft themselves, and we need such a new version for basic IPv6 support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5f3029c..ad4efdb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,16 +80,9 @@ if(NOT DEFINED BUILD_WINVNC)
set(BUILD_WINVNC 1)
endif()
-# Minimum version is Windows 2000 (5.0)
+# Minimum version is Windows XP SP2 (5.2)
if(WIN32)
- if(NOT CMAKE_SIZEOF_VOID_P MATCHES 8)
- add_definitions(-D_WIN32_IE=0x0500 -D_WIN32_WINNT=0x0500)
- else()
- set(WIN64 1)
- # Win64 doesn't like us requesting a Windows version that didn't have
- # 64-bit support. Request XP (5.1) instead.
- add_definitions(-D_WIN32_IE=0x0501 -D_WIN32_WINNT=0x0501)
- endif()
+ add_definitions(-D_WIN32_IE=0x0502 -D_WIN32_WINNT=0x0502)
endif()
if(CMAKE_SIZEOF_VOID_P MATCHES 8)