aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-08-22 15:10:22 +0200
committerPierre Ossman <ossman@cendio.se>2014-08-22 15:10:22 +0200
commit4f3ac69a11b98aa7eea88a6336140bced4c66eae (patch)
tree195546fd1a02c65b86bf03c2d0b25e51552a767a /CMakeLists.txt
parent796580af8791db18cf95f32784c0270085f0b361 (diff)
downloadtigervnc-4f3ac69a11b98aa7eea88a6336140bced4c66eae.tar.gz
tigervnc-4f3ac69a11b98aa7eea88a6336140bced4c66eae.zip
Add xhandler hook
Boiler plate code to intercept system events from FLTK so that we can generate proper keyboard messages.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30520a51..f5a016ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -300,6 +300,9 @@ if(FLTK_FOUND)
# FLTK STR #2860
check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { void (Fl_Window::*foo)(int,int,int,int) = &Fl_Window::fullscreen_screens; return 0; }" HAVE_FLTK_FULLSCREEN_SCREENS)
+ # FLTK STR #xxxx
+ check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::add_xhandler(NULL, NULL); return 0; }" HAVE_FLTK_XHANDLERS)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()