aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-03-17 13:35:33 +0100
committerPierre Ossman <ossman@cendio.se>2015-03-17 13:35:33 +0100
commit70b51fe03244b52f8635a500d7444f97425d5ab4 (patch)
treebcc9ea4bfacf5ac424d0db8a7765701d73faae5e /CMakeLists.txt
parent725121715eef5b315226c0b8a0ed4cde9a273382 (diff)
downloadtigervnc-70b51fe03244b52f8635a500d7444f97425d5ab4.tar.gz
tigervnc-70b51fe03244b52f8635a500d7444f97425d5ab4.zip
stop setting CMAKE_EXTRA_INCLUDE_FILES for check_function_exists()
It ignores it anyway.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad4efdb0..3f11676e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -254,10 +254,7 @@ set(HAVE_PAM ${ENABLE_PAM})
# Check for socket functions
if(WIN32)
- set(CMAKE_EXTRA_INCLUDE_FILES winsock2.h ws2tcpip.h)
set(CMAKE_REQUIRED_LIBRARIES ws2_32)
-else()
- set(CMAKE_EXTRA_INCLUDE_FILES sys/socket.h)
endif()
check_function_exists(inet_aton HAVE_INET_ATON)
# This might give a false positive on Windows as it is also guarded by
@@ -267,7 +264,6 @@ if(NOT WIN32)
check_function_exists(inet_pton HAVE_INET_PTON)
endif()
check_function_exists(getaddrinfo HAVE_GETADDRINFO)
-set(CMAKE_EXTRA_INCLUDE_FILES)
set(CMAKE_REQUIRED_LIBRARIES)
# Generate config.h and make sure the source finds it