aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-06-24 03:19:28 +0000
committerDRC <dcommander@users.sourceforge.net>2011-06-24 03:19:28 +0000
commit56e625c5da1bbac86d5e73fed822a73b0b9b20cd (patch)
treedd2d3eff13b96a07d71ec0f116ceaf852c5dec73 /CMakeLists.txt
parent50214b7a663fb17f94f02549af3f6d8a29cfbd43 (diff)
downloadtigervnc-56e625c5da1bbac86d5e73fed822a73b0b9b20cd.tar.gz
tigervnc-56e625c5da1bbac86d5e73fed822a73b0b9b20cd.zip
Visual C++ requires gcrypt.h because it doesn't have ssize_t. Also, building with the GnuTLS static libs (using MinGW) requires user32 and ws2_32.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4529 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0fdd3c66..ace5ffa3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -241,6 +241,10 @@ if(ENABLE_GNUTLS)
set(CMAKE_REQUIRED_FLAGS -I${GNUTLS_INCLUDE_DIR})
set(CMAKE_EXTRA_INCLUDE_FILES gnutls/gnutls.h)
set(CMAKE_REQUIRED_LIBRARIES ${GNUTLS_LIBRARIES})
+ if(WIN32)
+ set(CMAKE_EXTRA_INCLUDE_FILES gcrypt.h ${CMAKE_EXTRA_INCLUDE_FILES})
+ set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ws2_32 user32)
+ endif()
if(ZLIB_FOUND)
# When we build against the static version of GnuTLS, we also use the
# included version of Zlib, but it isn't built yet, so we have to use the