summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-09-11 10:48:29 +0200
committerPierre Ossman <ossman@cendio.se>2014-09-11 10:48:29 +0200
commit64ff1ca14f595d0eb7f6b1b47facf5f4147eae51 (patch)
treed3c9fb78039160cd09ef080303854545e3367eec /CMakeLists.txt
parent6d66d6deb790545dd475f3e74cf817be97d23cea (diff)
downloadtigervnc-64ff1ca14f595d0eb7f6b1b47facf5f4147eae51.tar.gz
tigervnc-64ff1ca14f595d0eb7f6b1b47facf5f4147eae51.zip
Update FLTK patches based on feeback from upstream
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a3e0931a..5f4ccd48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -301,7 +301,7 @@ if(FLTK_FOUND)
check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { void (Fl_Window::*foo)(int,int,int,int) = &Fl_Window::fullscreen_screens; return 0; }" HAVE_FLTK_FULLSCREEN_SCREENS)
# FLTK STR #xxxx
- check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::add_xhandler(NULL, NULL); return 0; }" HAVE_FLTK_XHANDLERS)
+ check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::add_system_handler(NULL, NULL); return 0; }" HAVE_FLTK_XHANDLERS)
# FLTK STR #xxxx
check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::disable_im(); return 0; }" HAVE_FLTK_IM)