summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-06-08 17:02:36 +0000
committerPierre Ossman <ossman@cendio.se>2011-06-08 17:02:36 +0000
commit835b4ef7cdf7df1f91aa0d337a5a4537011d4742 (patch)
tree9131abc63a9f55bc265c6d77aba6bada7911ba71 /CMakeLists.txt
parent494271583e29d6d15036989322c62f88f941bc32 (diff)
downloadtigervnc-835b4ef7cdf7df1f91aa0d337a5a4537011d4742.tar.gz
tigervnc-835b4ef7cdf7df1f91aa0d337a5a4537011d4742.zip
Add support for cursors to the new viewer.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4472 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94b05b91..33606267 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -194,6 +194,9 @@ if(BUILD_NEW_VNCVIEWER)
if(X11_Xfixes_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xfixes_LIB})
endif()
+ if(X11_Xcursor_FOUND)
+ set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xcursor_LIB})
+ endif()
set(CMAKE_REQUIRED_INCLUDES ${FLTK_INCLUDE_DIR})
set(CMAKE_REQUIRED_LIBRARIES ${FLTK_LIBRARIES})
@@ -210,6 +213,9 @@ if(BUILD_NEW_VNCVIEWER)
# FLTK STR #2641
check_cxx_source_compiles("#include <FL/Enumerations.H>\nint main(int c, char** v) { return FL_FULLSCREEN; }" HAVE_FLTK_FULLSCREEN)
+ # FLTK STR #2660
+ check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { void (Fl_Window::*foo)(const Fl_RGB_Image*,int,int) = &Fl_Window::cursor; return 0; }" HAVE_FLTK_CURSOR)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()