summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2012-07-13 11:22:55 +0000
committerPierre Ossman <ossman@cendio.se>2012-07-13 11:22:55 +0000
commitaae3891bc7380c23322214b9e2781b636c3d7199 (patch)
treea8cb23609213f033c42b3486eb2871f686504aad /CMakeLists.txt
parentc314d08990d063d064498c654d0b4652437a304f (diff)
downloadtigervnc-aae3891bc7380c23322214b9e2781b636c3d7199.tar.gz
tigervnc-aae3891bc7380c23322214b9e2781b636c3d7199.zip
Implement client side multi-head support. Requires a FLTK patched to support
fullscreen over multiple monitors. Will properly report screen configuration to the server, provided the server supports it. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4935 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cf3dd32..c375314a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,6 +289,9 @@ if(FLTK_FOUND)
# FLTK STR #2816
check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { Fl_Window::default_icons(0, 0); return 0; }" HAVE_FLTK_ICONS)
+ # FLTK STR #2860
+ check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { void (Fl_Window::*foo)(int,int,int,int) = &Fl_Window::fullscreen_screens; return 0; }" HAVE_FLTK_FULLSCREEN_SCREENS)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()