summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-07-05 18:55:55 +0000
committerDRC <dcommander@users.sourceforge.net>2011-07-05 18:55:55 +0000
commitc3a8517879106e88236786da76e2f1e292a7d0e1 (patch)
treef8e2a3ab3960bc6a39c25422963b796fa960c660 /CMakeLists.txt
parentdb56f5132a455efa753b300453b6efb9db794bfa (diff)
downloadtigervnc-c3a8517879106e88236786da76e2f1e292a7d0e1.tar.gz
tigervnc-c3a8517879106e88236786da76e2f1e292a7d0e1.zip
The previous fix for eliminating the console window in vncviewer.exe was not portable (it only worked in MinGW, which isn't what most people use.) Use the CMake "WIN32" target property instead.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4576 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cda85ca1..159de720 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,9 +309,6 @@ add_subdirectory(common)
if(WIN32)
add_subdirectory(win)
- if(CMAKE_C_COMPILER_ID STREQUAL GNU)
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-subsystem,windows")
- endif(CMAKE_C_COMPILER_ID STREQUAL GNU)
else()
# No interest in building x related parts on Apple
if(NOT APPLE)