summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-09-14 20:18:23 +0000
committerDRC <dcommander@users.sourceforge.net>2011-09-14 20:18:23 +0000
commitce33190fbed3cb1e231348e1949a9572fcc1e26a (patch)
treee43d87464a23991be2b3256e0b283667df2ce4cd /CMakeLists.txt
parentc3f1be6fb57d6b82c308bdceb01879ab750abccd (diff)
downloadtigervnc-ce33190fbed3cb1e231348e1949a9572fcc1e26a.tar.gz
tigervnc-ce33190fbed3cb1e231348e1949a9572fcc1e26a.zip
Oops. Apple version doesn't need to link with libdl, and we don't want to clobber the existing value of FLTK_LIBRARIES.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4674 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d8645a9..3cee4a60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -314,8 +314,7 @@ if(BUILD_NEW_VNCVIEWER)
set(FLTK_LIBRARIES)
if(APPLE)
set(FLTK_LIBRARIES "-framework Carbon -framework Cocoa -framework ApplicationServices")
- endif()
- if(NOT WIN32)
+ elseif(NOT WIN32)
set(FLTK_LIBRARIES "-ldl")
endif()
message(STATUS "Using included FLTK library")