summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoel Teichroeb <joel@teichroeb.net>2016-07-12 20:52:04 -0700
committerJoel Teichroeb <joel@teichroeb.net>2016-07-12 20:52:04 -0700
commitec7120134852c13bf72cec83da63e5fda415f371 (patch)
treec10496a4476fff425a1717f61a770f9268f1e3e7 /CMakeLists.txt
parentd175da71898789dc3122e6c34feb781f31cd1529 (diff)
downloadtigervnc-ec7120134852c13bf72cec83da63e5fda415f371.tar.gz
tigervnc-ec7120134852c13bf72cec83da63e5fda415f371.zip
Check CMake version for MinGW RC file handling
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 724aa939..a9e7f4e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,8 +104,9 @@ else()
message(STATUS "32-bit build")
endif()
-# CMake doesn't properly support resource compilation with MinGW. Boo!
-if(MINGW)
+# Versions of CMake before 2.8.7 do not properly support resource compilation
+# with MinGW. Boo!
+if(MINGW AND "${CMAKE_VERSION}" VERSION_LESS "2.8.7")
if(NOT DEFINED RC)
set(CMAKE_RC_COMPILER_INIT windres)
else()