aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2012-01-23 15:43:42 +0000
committerPierre Ossman <ossman@cendio.se>2012-01-23 15:43:42 +0000
commit2f4fd6b9203f0ade624ff8500c3a8a8c8711db61 (patch)
tree2fb55546121e57d8ac1b6d651d1c8527ca5131a3 /CMakeLists.txt
parent60d61586564a04806cbdab6d4b89004249ab292a (diff)
downloadtigervnc-2f4fd6b9203f0ade624ff8500c3a8a8c8711db61.tar.gz
tigervnc-2f4fd6b9203f0ade624ff8500c3a8a8c8711db61.zip
Failure to find FLTK dependencies is only fatal for our version of FLTK.
When using the system version we have to assume it's built the way the user wants. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4838 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 16 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88af909c..6f84b30f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,23 +247,15 @@ if(UNIX AND NOT APPLE)
# No proper handling for extra X11 libs that FLTK might need...
if(X11_Xft_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xft_LIB})
- else()
- message(FATAL_ERROR "Xft headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xinerama_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xinerama_LIB})
- else()
- message(FATAL_ERROR "Xinerama headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xfixes_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xfixes_LIB})
- else()
- message(FATAL_ERROR "Xfixes headers/libraries not found (needed by FLTK.)")
endif()
if(X11_Xcursor_FOUND)
set(FLTK_LIBRARIES ${FLTK_LIBRARIES} ${X11_Xcursor_LIB})
- else()
- message(FATAL_ERROR "Xcursor headers/libraries not found (needed by FLTK.)")
endif()
endif()
@@ -298,6 +290,22 @@ if(NOT FLTK_FOUND OR NOT HAVE_FLTK_DEAD_KEYS OR NOT HAVE_FLTK_CLIPBOARD
set(USE_INCLUDED_FLTK 1)
endif()
if(USE_INCLUDED_FLTK)
+ # Check that we have the proper dependencies
+ if(UNIX AND NOT APPLE)
+ if(NOT X11_Xft_FOUND)
+ message(FATAL_ERROR "Xft headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xinerama_FOUND)
+ message(FATAL_ERROR "Xinerama headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xfixes_FOUND)
+ message(FATAL_ERROR "Xfixes headers/libraries not found (needed by FLTK.)")
+ endif()
+ if(NOT X11_Xcursor_FOUND)
+ message(FATAL_ERROR "Xcursor headers/libraries not found (needed by FLTK.)")
+ endif()
+ endif()
+
set(HAVE_FLTK_DEAD_KEYS 1)
set(HAVE_FLTK_CLIPBOARD 1)
set(HAVE_FLTK_MEDIAKEYS 1)