aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2011-07-05 09:19:42 +0000
committerPeter Åstrand <astrand@cendio.se>2011-07-05 09:19:42 +0000
commitdb56f5132a455efa753b300453b6efb9db794bfa (patch)
treeaccfc87b657dd2d081343014b8e08653b70d98b1 /CMakeLists.txt
parent882a1d897aaf1f964f733fdcc39146b519626aa7 (diff)
downloadtigervnc-db56f5132a455efa753b300453b6efb9db794bfa.tar.gz
tigervnc-db56f5132a455efa753b300453b6efb9db794bfa.zip
Build with -Wl,-subsystem,windows on Windows, to avoid console window.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4575 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 159de720..cda85ca1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,6 +309,9 @@ add_subdirectory(common)
if(WIN32)
add_subdirectory(win)
+ if(CMAKE_C_COMPILER_ID STREQUAL GNU)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-subsystem,windows")
+ endif(CMAKE_C_COMPILER_ID STREQUAL GNU)
else()
# No interest in building x related parts on Apple
if(NOT APPLE)