summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-07-07 14:13:46 +0200
committerPierre Ossman <ossman@cendio.se>2014-07-07 14:13:46 +0200
commit5ad4d06006e96b1c7ff663ffcd5e406e06bae1c2 (patch)
tree659c6081230675758edcfb66a394fc1aa3e1bacb /CMakeLists.txt
parent890c10118c8a0db4fddb53a161f207c6ad23c130 (diff)
downloadtigervnc-5ad4d06006e96b1c7ff663ffcd5e406e06bae1c2.tar.gz
tigervnc-5ad4d06006e96b1c7ff663ffcd5e406e06bae1c2.zip
Remove a lot of platform compatibilty stuff
It's either not used, or no longer relevant.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2593a64b..c8de79f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -378,18 +378,10 @@ else()
set(CMAKE_EXTRA_INCLUDE_FILES sys/socket.h)
endif()
check_function_exists(inet_aton HAVE_INET_ATON)
-check_function_exists(inet_ntop HAVE_INET_NTOP)
check_function_exists(getaddrinfo HAVE_GETADDRINFO)
-check_type_size(socklen_t SOCKLEN_T)
set(CMAKE_EXTRA_INCLUDE_FILES)
set(CMAKE_REQUIRED_LIBRARIES)
-# Check for the newer standard string functions
-check_function_exists(snprintf HAVE_SNPRINTF)
-check_function_exists(strcasecmp HAVE_STRCASECMP)
-check_function_exists(strncasecmp HAVE_STRNCASECMP)
-check_function_exists(vsnprintf HAVE_VSNPRINTF)
-
# Generate config.h and make sure the source finds it
configure_file(config.h.in config.h)
add_definitions(-DHAVE_CONFIG_H)