summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Åstrand <astrand@cendio.se>2014-02-20 08:04:17 +0000
committerPeter Åstrand <astrand@cendio.se>2014-02-20 08:04:17 +0000
commit889b4896f46787aba1790724608c207666b7d4c8 (patch)
tree65a6481e144bde79bd09433018ca32abc44c60a5 /CMakeLists.txt
parent236b019980eb6e3eeb847705c4cbd795afc873b0 (diff)
downloadtigervnc-889b4896f46787aba1790724608c207666b7d4c8.tar.gz
tigervnc-889b4896f46787aba1790724608c207666b7d4c8.zip
Applied patch from:
Koichiro IWAO <meta@vmeta.jp> Option for disabling build of vncviewer. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@5161 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c78d15c..57b0f032 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -402,9 +402,12 @@ if(ENABLE_NLS)
add_subdirectory(po)
endif()
-add_subdirectory(vncviewer)
+option(BUILD_VIEWER "Build TigerVNC viewer" ON)
+if(BUILD_VIEWER)
+ add_subdirectory(vncviewer)
+ add_subdirectory(media)
+endif()
-add_subdirectory(media)
include(cmake/BuildPackages.cmake)