summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-05-20 14:55:10 +0000
committerPierre Ossman <ossman@cendio.se>2011-05-20 14:55:10 +0000
commitcb0cffe6dbe6b980227fc5683529a9478e1547b3 (patch)
tree9678f9ba73f98bda0c2413c353e0cc42b309fba3 /CMakeLists.txt
parent48c6a128038519b40c6c4f81401e929fadf44de8 (diff)
downloadtigervnc-cb0cffe6dbe6b980227fc5683529a9478e1547b3.tar.gz
tigervnc-cb0cffe6dbe6b980227fc5683529a9478e1547b3.zip
Add support for multimedia keys.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4437 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f38a0176..5ef2ee2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,6 +191,9 @@ if(BUILD_NEW_VNCVIEWER)
# FLTK STR #2636
check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::add_clipboard_notify(NULL, NULL); return 0; }" HAVE_FLTK_CLIPBOARD)
+ # FLTK STR #2638
+ check_cxx_source_compiles("#include <FL/Enumerations.H>\nint main(int c, char** v) { return FL_Volume_Down; }" HAVE_FLTK_MEDIAKEYS)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()