summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-03-08 13:05:27 +0000
committerPierre Ossman <ossman@cendio.se>2011-03-08 13:05:27 +0000
commit0153e23facf7c694bfaf17d60b092982e37ef633 (patch)
tree74e64ce7368776f8823927ba65ab74aa55522081 /CMakeLists.txt
parente1fd8e15f9d66fbc1efb7071cb32204f150be18d (diff)
downloadtigervnc-0153e23facf7c694bfaf17d60b092982e37ef633.tar.gz
tigervnc-0153e23facf7c694bfaf17d60b092982e37ef633.zip
Windows actually has socklen_t, it's just that it is in a special header.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4327 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f904b49a..40017c55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,12 +118,13 @@ include(CheckIncludeFiles)
include(CheckFunctionExists)
include(CheckTypeSize)
if(WIN32)
- set(CMAKE_EXTRA_INCLUDE_FILES winsock2.h)
+ set(CMAKE_EXTRA_INCLUDE_FILES winsock2.h ws2tcpip.h)
set(CMAKE_REQUIRED_LIBRARIES ws2_32)
+else()
+ set(CMAKE_EXTRA_INCLUDE_FILES sys/socket.h)
endif()
check_function_exists(inet_aton HAVE_INET_ATON)
check_function_exists(inet_ntop HAVE_INET_NTOP)
-set(CMAKE_EXTRA_INCLUDE_FILES sys/socket.h)
check_type_size(socklen_t SOCKLEN_T)
set(CMAKE_EXTRA_INCLUDE_FILES)