summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2012-07-03 14:52:26 +0000
committerPierre Ossman <ossman@cendio.se>2012-07-03 14:52:26 +0000
commit2137f4f78f2b80faf96707907cd08562d83f1216 (patch)
tree6b9c8f1e09c1dd343b65510d853ba9c3e62f1db6 /CMakeLists.txt
parentfe48cd4d2427c0262cd58b30c74331a9fce756c7 (diff)
downloadtigervnc-2137f4f78f2b80faf96707907cd08562d83f1216.tar.gz
tigervnc-2137f4f78f2b80faf96707907cd08562d83f1216.zip
GnuTLS 3.x has removed gnutls_transport_set_global_errno() in favour of
gnutls_transport_set_errno(). Make sure we call the right errno function depending on which GnuTLS we're using. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4922 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 252a42c8..9cf3dd32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -356,7 +356,8 @@ if(ENABLE_GNUTLS)
# system's version (if available) to perform this test.
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES};-lz)
endif()
- check_function_exists(gnutls_transport_set_global_errno HAVE_OLD_GNUTLS)
+ check_function_exists(gnutls_transport_set_errno HAVE_GNUTLS_SET_ERRNO)
+ check_function_exists(gnutls_transport_set_global_errno HAVE_GNUTLS_SET_GLOBAL_ERRNO)
check_function_exists(gnutls_x509_crt_print HAVE_GNUTLS_X509_CRT_PRINT)
check_type_size(gnutls_x509_crt_t GNUTLS_X509_CRT_T)
check_type_size(gnutls_datum_t GNUTLS_DATUM_T)