summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-06-22 06:00:57 +0000
committerDRC <dcommander@users.sourceforge.net>2011-06-22 06:00:57 +0000
commit61729dc902db44323d75c2164950779854cc3e37 (patch)
tree894ae113bf017373921a78655b0a713f9c9c1281 /CMakeLists.txt
parent2301beb51111bbf5b99b50485e5c505153d35a1f (diff)
downloadtigervnc-61729dc902db44323d75c2164950779854cc3e37.tar.gz
tigervnc-61729dc902db44323d75c2164950779854cc3e37.zip
Need to explicitly link with libiconv when using libintl.a.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4517 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95153a79..0d74e601 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,7 +154,7 @@ if(ENABLE_NLS)
find_library(LIBINTL_LIBRARY NAMES intl libintl)
check_library_exists(${LIBINTL_LIBRARY} "dgettext" "" LIBINTL_HAS_DGETTEXT)
if(LIBINTL_HAS_DGETTEXT)
- set(GETTEXT_LIBRARIES ${LIBINTL_LIBRARY})
+ set(GETTEXT_LIBRARIES ${LIBINTL_LIBRARY} ${ICONV_LIBRARIES})
set(GETTEXT_FOUND TRUE)
endif()
endif()