summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-11-19 14:16:00 +0100
committerPierre Ossman <ossman@cendio.se>2014-11-19 14:16:00 +0100
commit820c0ceb2ed92080e8d76d50b78ba01bd264baef (patch)
treee505f7f6cd8f43cf4e6e5f8b11d545cae36e2d5f /CMakeLists.txt
parent52927779375f55b271b5524fb60f0b007d721b50 (diff)
downloadtigervnc-820c0ceb2ed92080e8d76d50b78ba01bd264baef.tar.gz
tigervnc-820c0ceb2ed92080e8d76d50b78ba01bd264baef.zip
Assume inet_pton() is missing on Windows
It's much more difficult to test for this on Windows since the headers have version guards. Just play it safe and assume it is missing. We can remove this check when we raise the base requirements to Vista (or newer).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01b14e1f..2ff1a7c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -321,7 +321,12 @@ else()
set(CMAKE_EXTRA_INCLUDE_FILES sys/socket.h)
endif()
check_function_exists(inet_aton HAVE_INET_ATON)
+# This might give a false positive on Windows as it is also guarded by
+# a version check that we do not satisfy (requires Vista, but we target
+# Windows 2000).
+if(NOT WIN32)
check_function_exists(inet_pton HAVE_INET_PTON)
+endif()
check_function_exists(getaddrinfo HAVE_GETADDRINFO)
set(CMAKE_EXTRA_INCLUDE_FILES)
set(CMAKE_REQUIRED_LIBRARIES)