summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-03-08 13:08:15 +0000
committerPierre Ossman <ossman@cendio.se>2011-03-08 13:08:15 +0000
commitee0e362c18e8ed176de3db1f91ec01598cb58a50 (patch)
tree93e18c8882e0e77d846f4b104825907d205bbe62 /CMakeLists.txt
parent7f44326f4ad81ec1be365210a7cd4232c751cb56 (diff)
downloadtigervnc-ee0e362c18e8ed176de3db1f91ec01598cb58a50.tar.gz
tigervnc-ee0e362c18e8ed176de3db1f91ec01598cb58a50.zip
Separate and comment the platform tests a bit better.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4329 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efcd49d2..ebb86e28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,7 +117,7 @@ if(GNUTLS_FOUND)
add_definitions(${GNUTLS_DEFINITIONS})
endif()
-# Generate config.h
+# Check for socket functions
if(WIN32)
set(CMAKE_EXTRA_INCLUDE_FILES winsock2.h ws2tcpip.h)
set(CMAKE_REQUIRED_LIBRARIES ws2_32)
@@ -127,13 +127,16 @@ endif()
check_function_exists(inet_aton HAVE_INET_ATON)
check_function_exists(inet_ntop HAVE_INET_NTOP)
check_type_size(socklen_t SOCKLEN_T)
-
set(CMAKE_EXTRA_INCLUDE_FILES)
set(CMAKE_REQUIRED_LIBRARIES)
+
+# Check for the newer standard string functions
check_function_exists(snprintf HAVE_SNPRINTF)
check_function_exists(strcasecmp HAVE_STRCASECMP)
check_function_exists(strncasecmp HAVE_STRNCASECMP)
check_function_exists(vsnprintf HAVE_VSNPRINTF)
+
+# Generate config.h and make sure the source finds it
configure_file(config.h.cmake.in config.h)
add_definitions(-DHAVE_CONFIG_H)
include_directories(${CMAKE_BINARY_DIR})