summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2011-03-03 12:32:15 +0000
committerPierre Ossman <ossman@cendio.se>2011-03-03 12:32:15 +0000
commit481b03ecd4699056314c2c8661538e8bddfd6265 (patch)
tree5c181d18a845de232174727ea08ed892c0c4c0a0 /CMakeLists.txt
parent8fb1191522cc8447a0b9e543056e4c395097e94f (diff)
downloadtigervnc-481b03ecd4699056314c2c8661538e8bddfd6265.tar.gz
tigervnc-481b03ecd4699056314c2c8661538e8bddfd6265.zip
Consolidate all the Windows installer stuff to its own directory.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4316 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 112aa8d2..e855c407 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,40 +125,3 @@ add_definitions(-D_WIN32_IE=0x0500 -D_WIN32_WINNT=0x0500)
add_subdirectory(common)
add_subdirectory(win)
-
-
-#
-# Installer
-#
-
-if(64BIT)
- set(INST_NAME ${CMAKE_PROJECT_NAME}64-${VERSION})
- set(INST_DEFS -DWIN64)
-else()
- set(INST_NAME ${CMAKE_PROJECT_NAME}-${VERSION})
-endif()
-
-if(MSVC_IDE)
- set(INSTALLERDIR "$(OutDir)")
- set(BUILDDIRDEF "-DBUILD_DIR=${INSTALLERDIR}\\")
-else()
- set(INSTALLERDIR .)
- set(BUILDDIRDEF "-DBUILD_DIR=")
-endif()
-
-set(INST_DEPS vncviewer)
-
-if(BUILD_WINVNC)
- set(INST_DEFS ${INST_DEFS} -DBUILD_WINVNC)
- set(INST_DEPS ${INST_DEPS} winvnc4 wm_hooks vncconfig)
-endif()
-
-configure_file(win/tigervnc.iss.in tigervnc.iss)
-
-add_custom_target(installer
- iscc -o${INSTALLERDIR} ${INST_DEFS} ${BUILDDIRDEF} -F${INST_NAME} tigervnc.iss
- DEPENDS ${INST_DEPS}
- SOURCES tigervnc.iss)
-
-install(FILES ${CMAKE_SOURCE_DIR}/win/README_BINARY.txt
- ${CMAKE_SOURCE_DIR}/LICENCE.txt DESTINATION .)