summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-11-08 08:38:58 +0000
committerDRC <dcommander@users.sourceforge.net>2011-11-08 08:38:58 +0000
commit37596ddea2abe83634f077a7c54d374fcade3a95 (patch)
treecd4da45e367ad3daa408fa69c00d761aeb20ee22 /CMakeLists.txt
parentccc0969dd97ed55b063f79fc2b85011e48b765ca (diff)
downloadtigervnc-37596ddea2abe83634f077a7c54d374fcade3a95.tar.gz
tigervnc-37596ddea2abe83634f077a7c54d374fcade3a95.zip
Some platforms (I'm looking at you, MinGW64) have gettext but not iconv, so the build fails because iconv.h is missing. Thus, disable NLS if either gettext or iconv is not found.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4775 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbd1dc91..15e2f670 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -189,7 +189,7 @@ if(ENABLE_NLS)
endif()
endif()
- if(NOT GETTEXT_FOUND)
+ if(NOT GETTEXT_FOUND OR NOT ICONV_FOUND)
message(WARNING "Gettext NOT found. Native Language Support disabled.")
set(ENABLE_NLS 0)
endif()