summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2014-09-11 10:46:12 +0200
committerPierre Ossman <ossman@cendio.se>2014-09-11 10:46:12 +0200
commit6d66d6deb790545dd475f3e74cf817be97d23cea (patch)
tree642621fc2c24d4c286f591bb31e0558c43e606a6 /CMakeLists.txt
parent38fcebbb00d849d46158f66793ae0f7f3c7c7ec4 (diff)
downloadtigervnc-6d66d6deb790545dd475f3e74cf817be97d23cea.tar.gz
tigervnc-6d66d6deb790545dd475f3e74cf817be97d23cea.zip
Protect the optional IM disabling calls with #ifdef:s
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5a016ac..a3e0931a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -303,6 +303,9 @@ if(FLTK_FOUND)
# FLTK STR #xxxx
check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::add_xhandler(NULL, NULL); return 0; }" HAVE_FLTK_XHANDLERS)
+ # FLTK STR #xxxx
+ check_cxx_source_compiles("#include <FL/Fl.H>\nint main(int c, char** v) { Fl::disable_im(); return 0; }" HAVE_FLTK_IM)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()