summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDRC <dcommander@users.sourceforge.net>2011-07-06 07:23:51 +0000
committerDRC <dcommander@users.sourceforge.net>2011-07-06 07:23:51 +0000
commit7cf9fbc0a33786833e0ebb18d05655467532ef43 (patch)
tree98ba4066e661ce5d11e61f832822e286a28fb280 /CMakeLists.txt
parentc3a8517879106e88236786da76e2f1e292a7d0e1 (diff)
downloadtigervnc-7cf9fbc0a33786833e0ebb18d05655467532ef43.tar.gz
tigervnc-7cf9fbc0a33786833e0ebb18d05655467532ef43.zip
Fix regression. We need to set WIN64 so it will be properly defined in resdefs.h. Failing to do so causes the incorrect manifest file to be included in the Win64 version of WinVNC4.exe, which causes it to fail to run.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4577 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 159de720..ba72c992 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,6 +93,7 @@ if(WIN32)
if(NOT CMAKE_SIZEOF_VOID_P MATCHES 8)
add_definitions(-D_WIN32_IE=0x0500 -D_WIN32_WINNT=0x0500)
else()
+ set(WIN64 1)
# Win64 doesn't like us requesting a Windows version that didn't have
# 64-bit support. Request XP (5.1) instead.
add_definitions(-D_WIN32_IE=0x0501 -D_WIN32_WINNT=0x0501)