summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2012-03-27 12:50:54 +0000
committerPierre Ossman <ossman@cendio.se>2012-03-27 12:50:54 +0000
commit8eb3508b7365aefddf98671b1a962366d480b237 (patch)
treeb9737a1e6b7db3cdc826592314d4382748af9c2e /CMakeLists.txt
parent64127708e070f248f4db1ed57375de25c0ce0ce4 (diff)
downloadtigervnc-8eb3508b7365aefddf98671b1a962366d480b237.tar.gz
tigervnc-8eb3508b7365aefddf98671b1a962366d480b237.zip
Set a proper icon for the vncviewer windows on Unix and Windows.
git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@4878 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 708b2582..5db85c10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -250,7 +250,6 @@ endif()
# Check for FLTK
set(FLTK_SKIP_FLUID TRUE)
set(FLTK_SKIP_OPENGL TRUE)
-set(FLTK_SKIP_IMAGES TRUE)
set(FLTK_SKIP_FORMS TRUE)
find_package(FLTK)
@@ -292,6 +291,9 @@ if(FLTK_FOUND)
# FLTK STR #2660
check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { void (Fl_Window::*foo)(const Fl_RGB_Image*,int,int) = &Fl_Window::cursor; return 0; }" HAVE_FLTK_CURSOR)
+ # FLTK STR #2816
+ check_cxx_source_compiles("#include <FL/Fl_Window.H>\nint main(int c, char** v) { Fl_Window::default_icons(0, 0); return 0; }" HAVE_FLTK_ICONS)
+
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
endif()
@@ -300,7 +302,7 @@ option(USE_INCLUDED_FLTK
"Force the use of the FLTK library bundled with the TigerVNC source")
if(NOT FLTK_FOUND OR NOT HAVE_FLTK_DEAD_KEYS OR NOT HAVE_FLTK_CLIPBOARD
OR NOT HAVE_FLTK_MEDIAKEYS OR NOT HAVE_FLTK_FULLSCREEN
- OR NOT HAVE_FLTK_CURSOR)
+ OR NOT HAVE_FLTK_CURSOR OR NOT HAVE_FLTK_ICONS)
set(USE_INCLUDED_FLTK 1)
endif()
if(USE_INCLUDED_FLTK)
@@ -325,6 +327,7 @@ if(USE_INCLUDED_FLTK)
set(HAVE_FLTK_MEDIAKEYS 1)
set(HAVE_FLTK_FULLSCREEN 1)
set(HAVE_FLTK_CURSOR 1)
+ set(HAVE_FLTK_ICONS 1)
set(FLTK_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/common/fltk)
set(FLTK_LIBRARIES)
if(APPLE)