summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
committerPierre Ossman <ossman@cendio.se>2015-02-03 09:54:49 +0100
commitcc8c6a296f48552dde4375c5b491225262b4814f (patch)
tree3aa592a2b67137cd60664cda546404f15daa12a1 /CMakeLists.txt
parent27eb55e1975c4f558f6a53d573091e76064cc8e7 (diff)
downloadtigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.tar.gz
tigervnc-cc8c6a296f48552dde4375c5b491225262b4814f.zip
Drop bundled zlib
We're not doing a sufficient job of keeping this updated so list it as an external requirement instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 882077ad..f732f2f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,14 +116,7 @@ if(UNIX AND NOT APPLE)
endif()
# Check for zlib
-find_package(ZLIB)
-option(USE_INCLUDED_ZLIB "Force use of the bundled zlib")
-if(NOT ZLIB_FOUND)
- set(USE_INCLUDED_ZLIB 1)
-endif()
-if(USE_INCLUDED_ZLIB)
- message(STATUS "Using included zlib library")
-endif()
+find_package(ZLIB REQUIRED)
# Check for gettext
option(ENABLE_NLS "Enable translation of program messages" ON)