summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2015-03-12 11:15:32 +0100
committerPierre Ossman <ossman@cendio.se>2015-03-12 11:15:32 +0100
commitd1cb31f43636e574058f64ac3e5e4cbe20f162b4 (patch)
tree1260ce593ca99b9fe22eb51b906f54b2c0f567fe /common/CMakeLists.txt
parent59b4bc5638ced3cb5f043ccd9ed207fe76148d1a (diff)
parent4cf2d3a621ecb9918b57021bc1cee1bd016dc0aa (diff)
downloadtigervnc-d1cb31f43636e574058f64ac3e5e4cbe20f162b4.tar.gz
tigervnc-d1cb31f43636e574058f64ac3e5e4cbe20f162b4.zip
Merge branch 'upreqs' of https://github.com/CendioOssman/tigervnc
Conflicts: contrib/packages/rpm/el5/SPECS/tigervnc.spec vncviewer/Viewport.cxx
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index a645aa58..16e2a35e 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -1,10 +1,3 @@
-if(USE_INCLUDED_ZLIB)
- add_subdirectory(zlib)
-
- set(ZLIB_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/common/zlib)
- set(ZLIB_LIBRARIES zlib)
-endif()
-
add_subdirectory(os)
add_subdirectory(rdr)
add_subdirectory(network)
@@ -19,7 +12,4 @@ add_subdirectory(rfb)
if(CMAKE_COMPILER_IS_GNUCXX AND (CMAKE_SIZEOF_VOID_P MATCHES 8) AND NOT WIN32)
set_target_properties(os rdr network Xregion rfb
PROPERTIES COMPILE_FLAGS -fPIC)
- if(USE_INCLUDED_ZLIB)
- set_target_properties(zlib PROPERTIES COMPILE_FLAGS -fPIC)
- endif()
endif()