summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2008-10-22 14:47:09 +0000
committerAdam Tkac <atkac@redhat.com>2008-10-22 14:47:09 +0000
commita0d5fe3790af8c284be9ddc0ca369ecf21c67195 (patch)
tree958bee2a153c5c51bc97d1e40153b46c84cbf149 /common/Makefile.am
parent65b24feda1556dea7a4a7a92a162d5c6b0de13ce (diff)
downloadtigervnc-a0d5fe3790af8c284be9ddc0ca369ecf21c67195.tar.gz
tigervnc-a0d5fe3790af8c284be9ddc0ca369ecf21c67195.zip
[Bugfix] Handle conditional jpeg/zlib building through AM_CONDITIONAL to make
make dist working [Bugfix] #include <jpeglib.h> (not jpeg/jpeglib.h) in JpegCompressor.h git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3043 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index ef1cdaa4..905a2b2d 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1 +1,10 @@
-SUBDIRS = @ZLIB_DIR@ @JPEG_DIR@ rdr network Xregion rfb
+SUBDIRS =
+
+if INCLUDED_ZLIB
+SUBDIRS += zlib
+endif
+if INCLUDED_JPEG
+SUBDIRS += jpeg
+endif
+
+SUBDIRS += rdr network Xregion rfb