summaryrefslogtreecommitdiffstats
path: root/common/jpeg/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2009-06-29 11:20:42 +0000
committerPierre Ossman <ossman@cendio.se>2009-06-29 11:20:42 +0000
commit0b7301e22a0e7c90f7999210bada0e1984414a5f (patch)
treeb2983325774cbb5ca7b8c2203b04b7cf2d9a5f8f /common/jpeg/Makefile.am
parente0b83e173aeb83d5dea09b4498b866e797f07160 (diff)
downloadtigervnc-0b7301e22a0e7c90f7999210bada0e1984414a5f.tar.gz
tigervnc-0b7301e22a0e7c90f7999210bada0e1984414a5f.zip
Clean up SIMD glue code
The SIMD glue code has gotten a bit #ifdef heavy so clean it up by having one file for each possible SIMD arch. This also allows a simplification of the x86_64 code as SSE/SSE2 is always known to exist on that arch. git-svn-id: svn://svn.code.sf.net/p/tigervnc/code/trunk@3862 3789f03b-4d11-0410-bbf8-ca57d06f2519
Diffstat (limited to 'common/jpeg/Makefile.am')
-rw-r--r--common/jpeg/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/common/jpeg/Makefile.am b/common/jpeg/Makefile.am
index 57081f7e..0e7ae4d6 100644
--- a/common/jpeg/Makefile.am
+++ b/common/jpeg/Makefile.am
@@ -10,14 +10,17 @@ libjpeg_la_SOURCES = $(HDRS) jcapimin.c jcapistd.c jccoefct.c jccolor.c \
jddctmgr.c jdhuff.c jdinput.c jdmainct.c jdmarker.c jdmaster.c \
jdmerge.c jdphuff.c jdpostct.c jdsample.c jdtrans.c jerror.c \
jfdctflt.c jfdctfst.c jfdctint.c jidctflt.c jidctfst.c jidctint.c \
- jidctred.c jquant1.c jquant2.c jutils.c jmemmgr.c jmemnobs.c \
- jsimd.c
+ jidctred.c jquant1.c jquant2.c jutils.c jmemmgr.c jmemnobs.c
if WITH_SIMD
SUBDIRS = simd
libjpeg_la_LIBADD = simd/libsimd.la
+else
+
+libjpeg_la_SOURCES += jsimd_none.c
+
endif
TSTHDRS = turbojpeg.h rrutil.h rrtimer.h